
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.americanpress.com/content/tncms/live/" />
<meta name="keywords" content="state, local, news" />
<meta name="news_keywords" content="state, local, news" />
<meta name="description" content="U.S. Sen. Bill Cassidy urged senators Tuesday to approve legislation that would provide $500 billion in relief to state and local governments that have lost tax revenue because of COVID-19." />
<meta name="author" content="John  Guidroz" />
<meta property="article:author" content="https://www.facebook.com/JohnGuidrozAmericanPress" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/b/0b/b0bc3508-e2a7-5552-bf12-3e760c29180e/5f2d5d7dae25e.preview.jpg?crop=892%2C428%2C691%2C71&amp;resize=892%2C428&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="892" />
<meta property="og:image:height" content="428" />
<meta property="og:title" content="Cassidy: &lsquo;We cannot let Americans down&rsquo;" />
<meta property="og:description" content="U.S. Sen. Bill Cassidy urged senators Tuesday to approve legislation that would provide $500 billion in relief to state and local governments that have lost tax revenue because of COVID-19." />
<meta property="og:site_name" content="Lake Charles American Press" />
<meta property="og:section" content="State" />
<meta property="fb:app_id" content="313125259193052" />
<meta property="article:publisher" content="https://www.facebook.com/americanpress/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@AmericanPress" />
<meta name="twitter:creator" content="@https://www.twitter.com/JohnAmPress" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.e3f71549ece3260d6aaa86ed5ffcc035.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.c9c732b035a293475d6df8121863ef5a.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Arapey|Montserrat:400,700"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/news\/state","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"John  Guidroz","id":"b0bc3508-e2a7-5552-bf12-3e760c29180e","app":"editorial"},"vendor":{"outbrain":"headlines","taboola":""},"ad":{"vendor":"dfp premium"},"system":{"render_time":272},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-31537609-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["state","local","news"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.e2581800cba1f328853618263e9a8b3f.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/americanpress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            
                gptAdSlots['fixed-impact-top'] = googletag.defineSlot(adUnit, [2,1], 'fixed-impact-top').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-impact-top'].setTargeting('pos', ['fixed-impact-top','atf']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[728,90], [970,90], [970,250]]).addSize([1200, 0], [[728,90], [970,90], [970,250]]).build();
                gptAdSlots['fixed-leaderboard-top'] = googletag.defineSlot(adUnit, [[728,90], [970,90], [970,250]], 'fixed-leaderboard-top').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-top'].setTargeting('pos', ['fixed-leaderboard-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], [728,90]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-leaderboard-top-tablet'] = googletag.defineSlot(adUnit, [728,90], 'fixed-leaderboard-top-tablet').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-top-tablet'].setTargeting('pos', ['fixed-leaderboard-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], []).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-leaderboard-top-mobile'] = googletag.defineSlot(adUnit, [320,50], 'fixed-leaderboard-top-mobile').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-top-mobile'].setTargeting('pos', ['fixed-leaderboard-top','atf']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300,250]).addSize([768, 0], []).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-big-ad-top-mobile'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-top-mobile').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-top-mobile'].setTargeting('pos', ['fixed-big-ad-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [300,250]).addSize([1200, 0], [300,250]).build();
                gptAdSlots['fixed-big-ad-top-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-top-asset').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-top-asset'].setTargeting('pos', ['fixed-big-ad-top-asset','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300,250]).addSize([768, 0], []).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-big-ad-bottom-mobile'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-bottom-mobile').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-bottom-mobile'].setTargeting('pos', ['fixed-big-ad-bottom','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [300,250]).addSize([1200, 0], [300,250]).build();
                gptAdSlots['fixed-big-ad-bottom-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-bottom-asset').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-bottom-asset'].setTargeting('pos', ['fixed-big-ad-bottom-asset','atf']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250], [300,600]]).addSize([1200, 0], [[300,250], [300,600]]).build();
                gptAdSlots['fixed-big-ad-top'] = googletag.defineSlot(adUnit, [[300,250], [300,600]], 'fixed-big-ad-top').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-top'].setTargeting('pos', ['fixed-big-ad-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250], [300,600]]).addSize([1200, 0], [[300,250], [300,600]]).build();
                gptAdSlots['fixed-big-ad-middle'] = googletag.defineSlot(adUnit, [[300,250], [300,600]], 'fixed-big-ad-middle').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-middle'].setTargeting('pos', ['fixed-big-ad-middle','stf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250], [300,600]]).addSize([1200, 0], [[300,250], [300,600]]).build();
                gptAdSlots['fixed-big-ad-bottom'] = googletag.defineSlot(adUnit, [[300,250], [300,600]], 'fixed-big-ad-bottom').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-bottom'].setTargeting('pos', ['fixed-big-ad-bottom','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"50811508-0527-11e8-9a58-734c6d3a8ee0-549007","asset_id":"50811508-0527-11e8-9a58-734c6d3a8ee0","title":"What other kind of newsletters do you want to see?","url":"\/what-other-kind-of-newsletters-do-you-want-to-see\/poll_50811508-0527-11e8-9a58-734c6d3a8ee0.html","results":"https:\/\/www.americanpress.com\/what-other-kind-of-newsletters-do-you-want-to-see\/poll_50811508-0527-11e8-9a58-734c6d3a8ee0.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[728,90], [970,90], [970,250]]).addSize([1200, 0], [[728,90], [970,90], [970,250]]).build();
                gptAdSlots['fixed-leaderboard-bottom'] = googletag.defineSlot(adUnit, [[728,90], [970,90], [970,250]], 'fixed-leaderboard-bottom').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-bottom'].setTargeting('pos', ['fixed-leaderboard-bottom','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], []).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-leaderboard-bottom-mobile'] = googletag.defineSlot(adUnit, [320,50], 'fixed-leaderboard-bottom-mobile').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-bottom-mobile'].setTargeting('pos', ['fixed-leaderboard-bottom','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/TAP/news/state';
            
                gptAdSlots['fixed-impact-bottom'] = googletag.defineSlot(adUnit, [1,1], 'fixed-impact-bottom').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-impact-bottom'].setTargeting('pos', ['fixed-impact-bottom','btf']);
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Cassidy: ‘We cannot let Americans down’ | State | americanpress.com</title>
            
    <style>body { background-color: #F4F4F4; color: #565656; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #68838B; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #F4F4F4; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #F4F4F4; } .fixed-nav #main-navigation { background-color: #F4F4F4 !important; } #site-top-nav-container, #site-top-nav { background-color: #68838B; } #site-footer { background-color: #68838B; color: #F4F4F4; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000000; } .navbar-toggle .icon-bar { background-color: #000000 !important; } .navbar-toggle .sr-only-show { color: #000000 !important; } #site-top-nav .list-inline>li>a { color: #F4F4F4; } .asset .asset-body p, .asset #asset-content p { color: #565656; } #site-header { background-color: #F4F4F4; }/* remove full span bgs */ #site-navbar-container, #site-header-container, #site-top-nav-container { background-color: transparent !important; background-image: none !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000000; } }#site-copyright a, #site-footer a { color: #F4F4F4; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #68838B; }#site-header{ border-bottom: 3px solid #68838B; }#site-footer{ border-top: 3px solid #68838B; } .tnt-bg-accent { background-color: #68838B; } a .tnt-caret-down { color: #68838B; } .block-title .block-title-inner { border-color: #68838B; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #68838B; } .form-control:focus { border-bottom-color: #68838B; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ .double-pad-top {padding-top:20px;} </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /* font-family: 'Arapey', serif; font-family: 'Montserrat', sans-serif; */ body { font-family: 'Montserrat', sans-serif;} .navbar-default .navbar-nav>li>a { font-weight: normal!important; } .leaderboardTop { padding-top:12px;} .photo-carousel .item .photo-container { background-color: #e9eef3; } .block-title h1, .block-title h2, .block-title h3, .block-title h4, .block-title h5, .block-title h6 { font-family: 'Arapey', serif; text-transform:uppercase; font-weight:bold; } .block-title h3, .block-title h4 { padding: 7px; } .established-txt { position: relative; font-family: 'Arapey', serif; color: #ffffff; font-size: 22px; right: 90px; } .blue-header .block-title { background:#31689b!important; color:#ffffff!important;} /* why two declarations of the same */ .blue-header .block-title { background:#31689b!important; color:#ffffff!important;} .red-header .block-title { background:#bf4326!important; color:#ffffff!important;} .card-headline a { font-family: 'Arapey', serif;color:#000000;} .card-headline a:hover { color:#006d99;} .block-title .block-title-inner { padding: 0 15px 0px 0; } .btn-primary { background-color: #c9242a; border-color: #c9242a; } #site-footer { border-top: 0px solid #880109; } #site-footer-container { border-top: 0px solid #880109; } #site-footer a:hover { color:#abc6da;} span.tn-user-screenname { color: #e6edf3; } /* #block-537056 .list-popular > li:before {} */ /* #tntracking Customized by : wcline Date : 6/26/17 CRM : Description : Below hides the links to classifieds in the user dashboard. */ #user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(1) > div:nth-child(3){display:none;} #user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(1) > div:nth-child(2){display:none;} .section-users #accordion > div:nth-child(3) { display: none; } .section-users #accordion > div:nth-child(4) { display: none; } /* end #tntracking */ </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.americanpress.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/6134149e-dabc-11e7-a3e0-0f99b91513cf.jpg?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    <link rel="alternate" type="application/rss+xml" title="Cassidy: ‘We cannot let Americans down’ | State | americanpress.com" href="http://www.americanpress.com/search/?f=rss&amp;t=article&amp;c=news/state&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            <link rel="stylesheet" href="http://www.pulseresearch.com/intercept.css" >

<script type="text/javascript">
$(document).ready(function(){
$('div.panel-footer.user-signup.text-muted > p:contains("By submitting this form, you agree to our")').html('By submitting this form, you agree to our <a href="/site/privacy.html">Privacy Policy</a>.');
});

</script>








<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/2044412/POA_728x90', [728, 90], 'div-gpt-ad-1566322956409-0').addService(googletag.pubads());
googletag.defineSlot('/2044412/POA_300x600', [300, 600], 'div-gpt-ad-1566323352640-0').addService(googletag.pubads());
googletag.defineSlot('/2044412/POA_300x250', [300, 250], 'div-gpt-ad-1566323483405-0').addService(googletag.pubads());
googletag.defineSlot('/2044412/POA_160x600', [160, 600], 'div-gpt-ad-1566323690652-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<script type="text/javascript" src="//www.pulseresearch.com/web_intercepts/poa.js"></script>
<link rel="stylesheet" href="//www.pulseresearch.com/web_intercepts/poa.css">



        </head>
        <body class="app-editorial grid-boxy blox-asset uuid-b0bc3508-e2a7-5552-bf12-3e760c29180e section-newssection-state type-article infinity-disabled" data-authors='[]' data-path="/news/state">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.americanpress.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fnews%2Fstate&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=John++Guidroz&tncms.asset.id=b0bc3508-e2a7-5552-bf12-3e760c29180e&tncms.asset.app=editorial&tncms.vendor.outbrain=headlines&tncms.vendor.taboola=&tncms.ad.vendor=dfp+premium&tncms.system.render_time=272&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.google.ua=UA-31537609-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        <div class="tnt-ads-container text-center  " >
        <div id="fixed-impact-top" class="tnt-ads dfp-ad" style="min-height:1px; min-width:2px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-impact-top');
                        
                });
            </script>
        </div>
    </div>
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.americanpress.com/users/https://www.americanpress.com/tncms/admin/editorial-asset/?edit=b0bc3508-e2a7-5552-bf12-3e760c29180e"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.americanpress.com/users/admin/contribute/article/?from_section=/news/state"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
            <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
            <div class="asset-edit-message">You have permission to edit this article.</div>
            <div class="asset-edit-btns">
                <a class="btn btn-primary btn-sm" href="https://www.americanpress.com/tncms/admin/editorial-asset/?edit=b0bc3508-e2a7-5552-bf12-3e760c29180e"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
            </div>
        </div>

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-epaper">ePaper</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="https://lakecharlesla.circulationpro.com/scripts/WebObjects.exe/LakeCharlesSubscriberWeb"  target="_blank" rel="noopener" class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a href="/zsystem/olive-epaper-form/html_aaaf00c6-398f-11e7-ac83-77a37e59a3a6.html"  class="nav-link tnt-section-epaper-login">ePaper Login</a>
                                </li><li>
                                    <a href="http://www.americanpress.com/zsystem/years-ago-today/html_00b9983c-4f8e-11e7-b758-d7a51e811f9e.html"  target="_blank" rel="noopener" class="nav-link tnt-section-50-years-ago-today">50 Years Ago Today</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/advertising/"  class="nav-link tnt-section-advertising">Advertising</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="http://www.americanpress.com/circulation/american-press-rack-locations/article_e6786218-a475-11e7-b33b-8fc1275520ee.html"  target="_blank" rel="noopener" class="nav-link tnt-section-circulation">Circulation</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="https://lakecharlesla.circulationpro.com/scripts/WebObjects.exe/LakeCharlesSubscriberWeb"  target="_blank" rel="noopener" class="nav-link tnt-section-customer-login">Customer Login </a>
                                </li><li>
                                    <a href="/zsystem/newspaper-subscription/html_344cab5e-3a5c-11e7-8742-73f63a28f49f.html"  class="nav-link tnt-section-subscription">Subscription</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/zsystem/create-ad/html_052a1eb2-3b13-11e7-9559-a3ce8a189e9c.html"  class="nav-link tnt-section-create-ad">Create Ad</a>
                                </li><li>
                                    <a href="/site/classified.html"  class="nav-link tnt-section-information">Information</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/site/app.html"  class="nav-link tnt-section-mobile-app">Mobile App</a>
                                </li></ul></div></div></div>
                <div id="tncms-region-nav-mobile-nav-right-below" class="tncms-region-nav"><div id="mobile-nav-right-below_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/special-section/coronavirus/"  class="nav-link tnt-section-coronavirus">Coronavirus</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://americanpress.whatsopen.news/"  target="_blank" rel="noopener" class="nav-link tnt-section-whats-open">What's Open</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right-below_menu-child-4" data-target="#mobile-nav-right-below_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right-below_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/news/state/"  class="nav-link tnt-section-state">State</a>
                                </li><li>
                                    <a href="/news/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a href="/news/world/"  class="nav-link tnt-section-world">World</a>
                                </li><li>
                                    <a href="/news/crime/"  class="nav-link tnt-section-crime">Crime</a>
                                </li><li>
                                    <a href="/news/business/"  class="nav-link tnt-section-business">Business</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right-below_menu-child-5" data-target="#mobile-nav-right-below_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right-below_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/high-school"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a href="/sports/mcneese/"  class="nav-link tnt-section-mcneese">Mcneese</a>
                                </li><li>
                                    <a href="/sports/lsu/"  class="nav-link tnt-section-lsu">LSU</a>
                                </li><li>
                                    <a href="/sports/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a href="/sports/national/"  class="nav-link tnt-section-national">National</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right-below_menu-child-6" data-target="#mobile-nav-right-below_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right-below_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/jim-beam/"  class="nav-link tnt-section-jim-beam">Jim Beam</a>
                                </li><li>
                                    <a href="/opinion/scooter-hobbs/"  class="nav-link tnt-section-scooter-hobbs">Scooter Hobbs</a>
                                </li><li>
                                    <a href="/opinion/warren-arceneaux/"  class="nav-link tnt-section-warren-arceneaux">Warren Arceneaux</a>
                                </li><li>
                                    <a href="/opinion/david-berry/"  class="nav-link tnt-section-david-berry">David Berry</a>
                                </li><li>
                                    <a href="/site/forms/online_services/letter_editor"  class="nav-link tnt-section-submit-letter-to-the-editor">Submit Letter to the Editor</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/scene/"  class="nav-link tnt-section-scene">Scene</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://jobs.americanpress.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right-below_menu-child-9" data-target="#mobile-nav-right-below_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-obits">Obits</a>
                        </div>
                    </div><ul id="mobile-nav-right-below_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                                </li><li>
                                    <a href="/zsystem/submit-an-obituary/html_9cd4fffc-3c94-11e7-a36c-0fb3f2e93676.html"  class="nav-link tnt-section-submit-obituary">Submit Obituary</a>
                                </li><li>
                                    <a href="https://www.americanpress.com/site/forms/memorial_inquiry/"  target="_blank" rel="noopener" class="nav-link tnt-section-memorial-inquiry">Memorial Inquiry</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right-below_menu-child-10" data-target="#mobile-nav-right-below_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/photos/"  class="nav-link tnt-section-photos">Photos</a>
                        </div>
                    </div><ul id="mobile-nav-right-below_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a href="/photos/news/"  class="nav-link tnt-section-news">News</a>
                                </li><li>
                                    <a href="/photos/sports/"  class="nav-link tnt-section-sports">Sports</a>
                                </li><li>
                                    <a href="/photos/scene/"  class="nav-link tnt-section-scene">Scene</a>
                                </li></ul></div></div></div>
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-549076" class="tncms-block hidden-md hidden-lg"><div id="user-controls-549076" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.americanpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.americanpress.com/users/login/?referer_url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.americanpress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-549076').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.americanpress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.americanpress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.americanpress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-549076').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.americanpress.com/users/logout/" id="user-logout-form-549076"><input type="hidden" name="referer_url" value="https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-549072" class="tncms-block hidden-md hidden-lg"><section id="block-549072" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-549072" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-549072" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-549072-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-549072-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-549072-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-549072').submit();
        return false;
    });

    $('#site-search-549072').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-549072 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-549072 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-549072-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-epaper"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">ePaper</span>
                </a><ul id="topbar-col-one-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-subscribe"  href="/epaper/subscribe/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-epaper-login"  href="/epaper/epaper_login/" >
                    <span class="nav-label">ePaper Login</span>
                </a></li><li>
                <a class="nav-link  tnt-section-50-years-ago-today"  href="/epaper/50_years_ago_today/" >
                    <span class="nav-label">50 Years Ago Today</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-advertising"  href="/advertising/" >
                    <span class="nav-label">Advertising</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-circulation"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://www.americanpress.com/circulation/american-press-rack-locations/article_e6786218-a475-11e7-b33b-8fc1275520ee.html"  target="_blank" rel="noopener">
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Circulation</span>
                </a><ul id="topbar-col-one-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-customer-login"  href="https://lakecharlesla.circulationpro.com/scripts/WebObjects.exe/LakeCharlesSubscriberWeb"  target="_blank" rel="noopener">
                    <span class="nav-label">Customer Login </span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscription"  href="/zsystem/newspaper-subscription/html_344cab5e-3a5c-11e7-8742-73f63a28f49f.html" >
                    <span class="nav-label">Subscription </span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="https://www.americanpress.com/classifieds/"  target="_blank" rel="noopener">
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Classifieds</span>
                </a><ul id="topbar-col-one-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-create-ad"  href="/classifieds/create_ad/" >
                    <span class="nav-label">Create Ad</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classified-information"  href="https://www.americanpress.com/site/classified.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Classified Information</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-about-us"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/about.html" >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">About Us</span>
                </a><ul id="topbar-col-one-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-mobile-app"  href="/site/app.html" >
                    <span class="nav-label">Mobile App</span>
                </a></li></ul></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-549075" class="tncms-block"><div id="user-controls-549075" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.americanpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.americanpress.com/users/login/?referer_url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.americanpress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-549075').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.americanpress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.americanpress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.americanpress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-549075').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.americanpress.com/users/logout/" id="user-logout-form-549075"><input type="hidden" name="referer_url" value="https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-549073" class="tncms-block"><div class="follow-links-549073 pull-right">
    
    <section id="block-549073" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/americanpress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/AmericanPress/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/c/lcamericanpress" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/lcamericanpress/?hl=en" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.americanpress.com",
  "sameAs" : ["https://www.facebook.com/americanpress/","https://twitter.com/AmericanPress/","https://www.youtube.com/c/lcamericanpress","https://www.instagram.com/lcamericanpress/?hl=en"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-701467" class="tncms-block double-pad-top"><section id="block-701467" class="block emphasis-h3   " ><div class="block"><a href="https://jobs.americanpress.com/" rel="nofollow noopener" target="_blank">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d028a2da-37a7-11ea-8c51-3f94b847e066.png?resize=200%2C26 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d028a2da-37a7-11ea-8c51-3f94b847e066.png?resize=300%2C38 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d028a2da-37a7-11ea-8c51-3f94b847e066.png?resize=400%2C51 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d028a2da-37a7-11ea-8c51-3f94b847e066.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-959345" class="tncms-block double-pad-top"><section id="block-959345" class="block emphasis-h3   " ><div class="block"><a href="https://businessservices.americanpress.com/" rel="nofollow noopener" target="_blank">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d618987e-d2a4-11ea-bb96-eb937ec9fa37.png?resize=200%2C26 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d618987e-d2a4-11ea-bb96-eb937ec9fa37.png?resize=300%2C38 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d618987e-d2a4-11ea-bb96-eb937ec9fa37.png?resize=400%2C51 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d618987e-d2a4-11ea-bb96-eb937ec9fa37.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-755410" class="tncms-block double-pad-top"><section id="block-755410" class="block emphasis-h3   " ><div class="block"><a href="https://local.americanpress.com/" rel="nofollow noopener" target="_blank">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/c0b20768-41d7-11e9-99b1-3bdb87f21fc1.png?resize=200%2C26 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/c0b20768-41d7-11e9-99b1-3bdb87f21fc1.png?resize=300%2C38 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/c0b20768-41d7-11e9-99b1-3bdb87f21fc1.png?resize=400%2C51 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/c0b20768-41d7-11e9-99b1-3bdb87f21fc1.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-560181" class="tncms-block double-pad-top"><div id="site-logo-560181" class="site-logo-container text-center" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="https://www.americanpress.com/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=200%2C40" 
            srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=200%2C40 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=300%2C60 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=400%2C80 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=540%2C108 540w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=750%2C150 750w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=1200%2C240 1200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/9824cb68-36dd-11ea-9747-475f55577a83.png?resize=1700%2C340 1700w"
            sizes="(min-width: 1200px) 570px, 50vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"><div class="logo-date">
                Friday, August 7, 2020
            </div></div>
    </div></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-549077" class="tncms-block double-pad-top"><div id="weather-549077" class="weather-current size-large pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=70615" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc large">
                    <span class="temp">91&deg;</span>
                    
                        <span class="cond">Sunny <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="70615"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-549077 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Lake Charles, Louisiana
                                
                                 <small>(70615)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Abundant sunshine. High 93F. Winds ESE at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Generally clear. Low around 75F. Winds S at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: August 7, 2020 @ 11:45 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=70615"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-575916" class="tncms-block double-pad-top"><section id="block-575916" class="block emphasis-h3   " ><div class="block"><a href="http://www.americanpress.com/zsystem/newspaper-subscription/html_344cab5e-3a5c-11e7-8742-73f63a28f49f.html" rel="nofollow noopener" target="_blank">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/4f28137a-6a83-11e8-8cc3-cbb45b48182f.png?resize=200%2C26 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/4f28137a-6a83-11e8-8cc3-cbb45b48182f.png?resize=300%2C38 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/4f28137a-6a83-11e8-8cc3-cbb45b48182f.png?resize=400%2C51 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/4f28137a-6a83-11e8-8cc3-cbb45b48182f.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-549068" class="tncms-block"><section id="block-549068" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d40d55a8-4335-11e7-88c4-57224c8666bf.png?resize=200%2C27 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d40d55a8-4335-11e7-88c4-57224c8666bf.png?resize=300%2C40 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d40d55a8-4335-11e7-88c4-57224c8666bf.png?resize=400%2C53 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d40d55a8-4335-11e7-88c4-57224c8666bf.png?resize=540%2C72 540w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d40d55a8-4335-11e7-88c4-57224c8666bf.png?resize=750%2C100 750w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d40d55a8-4335-11e7-88c4-57224c8666bf.png?resize=1200%2C160 1200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/custom/image/d40d55a8-4335-11e7-88c4-57224c8666bf.png?resize=1700%2C227 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-549071" class="tncms-block"><ul id="site-search-549071-dropdown" class="hidden-print nav navbar-nav navbar-right site-search-full">
        <li class="search-form-dropdown dropdown yamm-fw">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-549071" action="/search/" method="GET" class="yamm-content">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm ">
        <input id="site-search-549071-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-549071-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-549071-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-549071').submit();
        return false;
    });

    $('#site-search-549071').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-549071 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-549071 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-549071-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-covid-19"  href="/special-section/coronavirus/" >
                    <span class="nav-label">COVID-19</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local"  href="/news/local/" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-state"  href="/news/state/" >
                    <span class="nav-label">State</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national"  href="/news/national/" >
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world"  href="/news/world/" >
                    <span class="nav-label">World</span>
                </a></li><li>
                <a class="nav-link  tnt-section-crime"  href="/news/crime/" >
                    <span class="nav-label">Crime</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-business"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/news/business/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Business</span>
                </a><ul id="main-nav_menu-child-3-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-shop-local"  href="/news/business/shop-local/" >
                    <span class="nav-label">Shop Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-face-to-face"  href="/news/business/face_to_face/" >
                    <span class="nav-label">Face to Face</span>
                </a></li></ul></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-high-school"  href="/sports/high-school" >
                    <span class="nav-label">High School</span>
                </a></li><li>
                <a class="nav-link  tnt-section-mcneese"  href="/sports/mcneese/" >
                    <span class="nav-label">McNeese</span>
                </a></li><li>
                <a class="nav-link  tnt-section-lsu"  href="/sports/lsu/" >
                    <span class="nav-label">LSU</span>
                </a></li><li>
                <a class="nav-link  tnt-section-outdoors"  href="/sports/outdoors/" >
                    <span class="nav-label">Outdoors</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national"  href="/sports/national/" >
                    <span class="nav-label">National</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-editorials"  href="/opinion/editorials/" >
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link  tnt-section-jim-beam"  href="/opinion/jim-beam" >
                    <span class="nav-label">Jim Beam</span>
                </a></li><li>
                <a class="nav-link  tnt-section-scooter-hobbs"  href="/opinion/scooter-hobbs/" >
                    <span class="nav-label">Scooter Hobbs</span>
                </a></li><li>
                <a class="nav-link  tnt-section-warren-arceneaux"  href="/opinion/warren-arceneaux/" >
                    <span class="nav-label">Warren Arceneaux</span>
                </a></li><li>
                <a class="nav-link  tnt-section-david-berry"  href="/opinion/david-berry/" >
                    <span class="nav-label">David Berry</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-letter-to-the-editor"  href="/site/forms/online_services/letter_editor" >
                    <span class="nav-label">Submit Letter to the Editor</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-scene"  href="/scene/" >
                    <span class="nav-label">Scene</span>
                </a></li><li>
                <a class="nav-link  tnt-section-jobs"  href="https://jobs.americanpress.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Jobs</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-life"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Life</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-submit-announcement"  href="https://www.americanpress.com/zsystem/announcements/html_fda0a47c-397d-11e7-9ca1-fb04a10a34fd.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Submit Announcement</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-obits"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/obituaries/" >
                    <span class="nav-label">Obits</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-obituary"  href="/zsystem/submit-an-obituary/html_9cd4fffc-3c94-11e7-a36c-0fb3f2e93676.html" >
                    <span class="nav-label">Submit Obituary</span>
                </a></li><li>
                <a class="nav-link  tnt-section-memorial-inquiry"  href="https://www.americanpress.com/site/forms/memorial_inquiry/"  target="_blank" rel="noopener">
                    <span class="nav-label">Memorial Inquiry</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-photos"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/photos/" >
                    <span class="nav-label">Photos</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-news"  href="/photos/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/photos/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-scene"  href="/photos/scene/" >
                    <span class="nav-label">Scene</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-whats-open"  href="https://americanpress.whatsopen.news/"  target="_blank" rel="noopener">
                    <span class="nav-label">What's Open</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
        <div id="top-container-breakout" class="container-breakout">
        <div class="visible-lg visible-md"><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-leaderboard-top" class="tnt-ads dfp-ad" style="min-height:90px; min-width:728px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-top');
                        
                });
            </script>
        </div>
    </div></div><div class="visible-sm"><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-leaderboard-top-tablet" class="tnt-ads dfp-ad" style="min-height:90px; min-width:728px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-top-tablet');
                        
                });
            </script>
        </div>
    </div></div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg " >
        <div id="fixed-leaderboard-top-mobile" class="tnt-ads dfp-ad" style="min-height:50px; min-width:320px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-top-mobile');
                        
                });
            </script>
        </div>
    </div>
       </div>
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-b0bc3508-e2a7-5552-bf12-3e760c29180e" class="asset article-default"  data-url="https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/b/0b/b0bc3508-e2a7-5552-bf12-3e760c29180e/5f2d5d7dae25e.preview.jpg?crop=892%2C428%2C691%2C71&resize=892%2C428&order=crop%2Cresize">
            <meta itemprop="width" content="892">
            <meta itemprop="height" content="428">
        </div>
        <meta itemprop="name" content="americanpress.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" />
    <style>
                .asset-paging .direction {
                    color: #68838B;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.americanpress.com\/tncms\/search\/mlt\/?origin=b0bc3508-e2a7-5552-bf12-3e760c29180e&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-b0bc3508-e2a7-5552-bf12-3e760c29180e" class="asset-paging">
                <div id="paging-prev-b0bc3508-e2a7-5552-bf12-3e760c29180e" class="paging-link prev offset"></div>
                <div id="paging-next-b0bc3508-e2a7-5552-bf12-3e760c29180e" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Cassidy: ‘We cannot let Americans down’
        </span>
    </h1>
    
    <h2 itemprop="alternativeHeadline" class="subhead">
            <span>Senator supports plan for state, local government funding </span>
        </h2><div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-7a37a4a0-3a63-11e7-927b-9ba95362f7b9-asset-b0bc3508-e2a7-5552-bf12-3e760c29180e" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.americanpress.com/users/profile/JohnGuidroz">John  Guidroz</a></span>
                
                    <div id="author-popup-7a37a4a0-3a63-11e7-927b-9ba95362f7b9-asset-b0bc3508-e2a7-5552-bf12-3e760c29180e-content" class="hide">
                        <article class="clearfix card author popup-content card-author-7a37a4a0-3a63-11e7-927b-9ba95362f7b9">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.americanpress.com/users/profile/JohnGuidroz" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="JohnGuidroz"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/avatars/7/a3/7a4/7a37a4a0-3a63-11e7-927b-9ba95362f7b9.0fc7b7e12d3b2e55cd1cef3a44ac29dd.png?_dc=1494959457"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.americanpress.com/users/profile/JohnGuidroz" rel="author" class="tnt-user-profile-link tnt-user-name">John  Guidroz</a>
                                </h4><p class="tnt-user-title small text-muted">Calcasieu Parish Government and Cameron Parish Reporter</p>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="https://www.facebook.com/JohnGuidrozAmericanPress" title="Facebook" target="_blank" rel="noopener">
                   <span class="sr-only">Author facebook</span>
                   <span class="tnt-stack">
                       
                       <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="https://www.linkedin.com/in/john-guidroz-35541a29/" title="LinkedIn" target="_blank" rel="noopener">
                    <span class="sr-only">Author linkedin</span>
                   <span class="tnt-stack">
                       
                       <i class="fab tnt-linkedin-in tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="https://www.twitter.com/JohnAmPress" title="Twitter" target="_blank" rel="noopener">
                    <span class="sr-only">Author twitter</span>
                    <span class="tnt-stack">
                       
                       <i class="fab tnt-twitter tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="mailto:jguidroz@americanpress.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-7a37a4a0-3a63-11e7-927b-9ba95362f7b9-asset-b0bc3508-e2a7-5552-bf12-3e760c29180e').popover({
                            content: $('#author-popup-7a37a4a0-3a63-11e7-927b-9ba95362f7b9-asset-b0bc3508-e2a7-5552-bf12-3e760c29180e-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2020-08-05T13:00:00-05:00" class="tnt-date asset-date text-muted">
            Aug 5, 2020
        </time></li>
            <li class="hidden-print"><time datetime="2020-08-05T13:00:00-05:00" class="tnt-date asset-date text-muted">Aug 5, 2020</time>
        <span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2020-08-07T08:56:52-05:00" class="tnt-date tnt-update-recent asset-date text-muted">2 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html#comments" class="cm"><span class="fas tnt-comments"></span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-08-05T13:00:00-05:00">
    <meta itemprop="datePublished" content="2020-08-05T13:00:00-05:00">
    <meta itemprop="dateModified" content="2020-08-07T03:56:52-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Cassidy%3A%20%E2%80%98We%20cannot%20let%20Americans%20down%E2%80%99&via=AmericanPress&url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.americanpress.com/tncms/asset/editorial/b0bc3508-e2a7-5552-bf12-3e760c29180e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BAmerican%20Press%5D%20Cassidy%3A%20%E2%80%98We%20cannot%20let%20Americans%20down%E2%80%99&body=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="b0bc3508-e2a7-5552-bf12-3e760c29180e">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Cassidy%3A%20%E2%80%98We%20cannot%20let%20Americans%20down%E2%80%99&via=AmericanPress&url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.americanpress.com/tncms/asset/editorial/b0bc3508-e2a7-5552-bf12-3e760c29180e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BAmerican%20Press%5D%20Cassidy%3A%20%E2%80%98We%20cannot%20let%20Americans%20down%E2%80%99&body=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-b0bc3508-e2a7-5552-bf12-3e760c29180e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="b0bc3508-e2a7-5552-bf12-3e760c29180e" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="b0bc3508-e2a7-5552-bf12-3e760c29180e" class="save-list-b0bc3508-e2a7-5552-bf12-3e760c29180e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="b0bc3508-e2a7-5552-bf12-3e760c29180e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>U.S. Sen. Bill Cassidy urged senators Tuesday to approve legislation that would provide $500 billion in relief to state and local governments that have lost tax revenue because of COVID-19.</p><p>The State and Municipal Assistance for Recovery and Transition (SMART) Act intends to provide financial assistance to communities that need it the most, said Cassidy, R-La. He said the tax base lost by state and local governments has threatened the ability to keep essential workers — such as firefighters, police, teachers and sanitation workers — employed. He said he understands concerns over spending. However, the overall goal of the measure is to avoid long-term economic damage.</p><p>"The cost of doing nothing is worse," Cassidy said. "The United States cannot fully recover economically if local communities cannot provide basic services, allowing commerce to flow. We cannot let Americans down in this time of tremendous need."</p><p>Financial assistance from the SMART Act would be dispersed equally three ways. One would be based on the percentage of a state's population. The second would be based on COVID-19 infection rates. The third would be based on the amount of income a state has lost from Jan. 1, 2020, to Dec. 31, 2020.</p><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg " >
        <div id="fixed-big-ad-top-mobile" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-top-mobile');
                        
                });
            </script>
        </div>
    </div><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-big-ad-top-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-top-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Cassidy said the legislation offers a fair formula that "prioritizes funding to the hardest hit" by COVID-19.</p><p>States could not use the funding to pay for "poor management decisions and overly generous and unfunded pension plans," he said.</p><p>Cities or parishes/counties would be eligible to receive funding once they can prove the amount of revenue lost over a year.</p><p>Cassidy said 22 parish presidents have signed letters expressing their support of the SMART Act.</p><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg " >
        <div id="fixed-big-ad-bottom-mobile" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-bottom-mobile');
                        
                });
            </script>
        </div>
    </div><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-big-ad-bottom-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-bottom-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Cassidy%3A%20%E2%80%98We%20cannot%20let%20Americans%20down%E2%80%99&via=AmericanPress&url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.americanpress.com/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.americanpress.com/tncms/asset/editorial/b0bc3508-e2a7-5552-bf12-3e760c29180e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BAmerican%20Press%5D%20Cassidy%3A%20%E2%80%98We%20cannot%20let%20Americans%20down%E2%80%99&body=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/state/cassidy-we-cannot-let-americans-down/article_b0bc3508-e2a7-5552-bf12-3e760c29180e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b0bc3508-e2a7-5552-bf12-3e760c29180e"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-b0bc3508-e2a7-5552-bf12-3e760c29180e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="b0bc3508-e2a7-5552-bf12-3e760c29180e" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="b0bc3508-e2a7-5552-bf12-3e760c29180e" class="save-list-b0bc3508-e2a7-5552-bf12-3e760c29180e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="b0bc3508-e2a7-5552-bf12-3e760c29180e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-7a37a4a0-3a63-11e7-927b-9ba95362f7b9">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.americanpress.com/users/profile/JohnGuidroz" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="JohnGuidroz"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/avatars/7/a3/7a4/7a37a4a0-3a63-11e7-927b-9ba95362f7b9.0fc7b7e12d3b2e55cd1cef3a44ac29dd.png?_dc=1494959457"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.americanpress.com/users/profile/JohnGuidroz" rel="author" class="tnt-user-profile-link tnt-user-name">John  Guidroz</a>
                                </h4><p class="tnt-user-title small text-muted">Calcasieu Parish Government and Cameron Parish Reporter</p>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="https://www.facebook.com/JohnGuidrozAmericanPress" title="Facebook" target="_blank" rel="noopener">
                   <span class="sr-only">Author facebook</span>
                   <span class="tnt-stack">
                       
                       <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="https://www.linkedin.com/in/john-guidroz-35541a29/" title="LinkedIn" target="_blank" rel="noopener">
                    <span class="sr-only">Author linkedin</span>
                   <span class="tnt-stack">
                       
                       <i class="fab tnt-linkedin-in tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="https://www.twitter.com/JohnAmPress" title="Twitter" target="_blank" rel="noopener">
                    <span class="sr-only">Author twitter</span>
                    <span class="tnt-stack">
                       
                       <i class="fab tnt-twitter tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="mailto:jguidroz@americanpress.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-7a37a4a0-3a63-11e7-927b-9ba95362f7b9" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=7a37a4a0-3a63-11e7-927b-9ba95362f7b9&amp;s=start_time&amp;sd=desc" data-subject="John  Guidroz" data-description="Whenever John  Guidroz posts new content, you'll get an email delivered to your inbox with a link." data-name="John  Guidroz notification" data-author-id="7a37a4a0-3a63-11e7-927b-9ba95362f7b9" data-user-url="https://www.americanpress.com/users/">
        <i class="fas tnt-star"></i> Follow John  Guidroz
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" >
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.americanpress.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.americanpress.com/users/login/?referer_url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.americanpress.com/users/signup/?referer_url=https%3A%2F%2Fwww.americanpress.com%2Fnews%2Fstate%2Fcassidy-we-cannot-let-americans-down%2Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-625629" class="tncms-block"><section id="block-625629" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-625629 ">
        <div class="block-title-inner">
            <h3>
                
                More from this section
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-bg-color card-compact">
        
        
            <div class=" row equal equal-wrap">
        
        <div class=" col-sm-4 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-625629-e4e3d870-b64e-51fd-9a6a-a3aae5104ae3" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-  tnt-section-news tnt-sub-section-state">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/state/la-lottery/article_e4e3d870-b64e-51fd-9a6a-a3aae5104ae3.html" class="tnt-asset-link">
        

        
            LA Lottery</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2020-08-06T22:46:25-05:00" class="tnt-date asset-date text-muted">13 hrs ago</time></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">BATON ROUGE, La. (AP) — These Louisiana lotteries were drawn Thursday: </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-625629-f9869cff-319c-5074-ad09-698238e13f1e" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-  tnt-section-news tnt-sub-section-state">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/state/winning-numbers-drawn-in-pick-4-game/article_f9869cff-319c-5074-ad09-698238e13f1e.html" class="tnt-asset-link">
        

        
            Winning numbers drawn in 'Pick 4' game</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2020-08-06T22:46:09-05:00" class="tnt-date asset-date text-muted">13 hrs ago</time></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">BATON ROUGE, La. (AP) — The winning numbers in Thursday evening's drawing of the Louisiana Lottery's "Pick 4" game were: </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-625629-4e045f40-3576-52d1-86a2-49dc91cd151d" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-  tnt-section-news tnt-sub-section-state">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/state/winning-numbers-drawn-in-pick-3-game/article_4e045f40-3576-52d1-86a2-49dc91cd151d.html" class="tnt-asset-link">
        

        
            Winning numbers drawn in 'Pick 3' game</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2020-08-06T22:46:08-05:00" class="tnt-date asset-date text-muted">13 hrs ago</time></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">BATON ROUGE, La. (AP) — The winning numbers in Thursday evening's drawing of the Louisiana Lottery's "Pick 3" game were: </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        <div class=" col-sm-4 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-625629-ffa3d2c3-de8a-56e2-bb8c-70d73e6599dc" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-  tnt-section-news tnt-sub-section-state">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/state/louisiana-inshore-shrimp-season-starts-monday-in-most-areas/article_ffa3d2c3-de8a-56e2-bb8c-70d73e6599dc.html" class="tnt-asset-link">
        

        
            Louisiana inshore shrimp season starts Monday in most areas</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2020-08-06T16:05:28-05:00" class="tnt-date asset-date text-muted">19 hrs ago</time></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">BATON ROUGE, La. (AP) — The fall inshore shrimp season will open Monday across most of Louisiana, but the Biloxi Marsh and part of the Mermentau River won’t open for another two weeks. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-625629-b3dcdd54-7643-5e2a-a40b-9034f07597aa" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-  tnt-section-news tnt-sub-section-state">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/state/family-of-4-rescued-found-clinging-to-overturned-boat/article_b3dcdd54-7643-5e2a-a40b-9034f07597aa.html" class="tnt-asset-link">
        

        
            Family of 4 rescued, found clinging to overturned boat</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2020-08-06T10:45:06-05:00" class="tnt-date asset-date text-muted">Aug 6, 2020</time></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">VENICE, La. (AP) — Two children and their parents clung to their overturned boat in the Gulf of Mexico until the Coast Guard could rescue them Wednesday afternoon. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-4 last-grid-item">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-625629-f3b432c1-63b5-516c-9727-d8c0822cda7d" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-  tnt-section-news tnt-sub-section-state">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/state/winning-numbers-drawn-in-pick-4-game/article_f3b432c1-63b5-516c-9727-d8c0822cda7d.html" class="tnt-asset-link">
        

        
            Winning numbers drawn in 'Pick 4' game</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2020-08-05T22:46:13-05:00" class="tnt-date asset-date text-muted">Aug 5, 2020</time></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">BATON ROUGE, La. (AP) — The winning numbers in Wednesday evening's drawing of the Louisiana Lottery's "Pick 4" game were: </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        
        <div class="clearfix hidden-xs"></div>
        
        
        </div>
        </div></section></div></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("832ed22d-3ce2-4937-9f93-e56306b8315c");
        var apiKey = "YDC2G9T2K4BXNCJ3XDMR";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-832ed22d-3ce2-4937-9f93-e56306b8315c';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div><div id="taboola-video-outstream"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.americanpress.com/tncms/asset/editorial/b0bc3508-e2a7-5552-bf12-3e760c29180e/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"><div id="tncms-block-548985" class="tncms-block visible-lg visible-md american-press-latest-news-block"><section id="block-548985" class="block emphasis-h4 light  " ><div class="clearfix">
    
    <div class="block-title title-548985 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-circle border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/business/us-adds-1-8-million-jobs-in-a-sign-that-hiring-has-weakened/article_c9086fab-ff1b-5344-a885-9ed6f75c557c.html" class="tnt-asset-link">
        

        
            US adds 1.8 million jobs in a sign that hiring has weakened</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/winfrey-demanding-justice-for-breonna-taylor-with-billboards/article_1bb48e1e-3831-567d-8317-7550be68461a.html" class="tnt-asset-link">
        

        
            Winfrey demanding justice for Breonna Taylor with billboards</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/cuomo-clears-new-york-schools-statewide-to-open-carefully/article_dc22a063-1f10-504d-81ba-f15565330a88.html" class="tnt-asset-link">
        

        
            Cuomo clears New York schools statewide to open, carefully</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/business/wall-street-stalls-s-p-500-drifts-after-5-day-win-streak/article_451c39fe-6422-594a-9ffc-930b18563c1d.html" class="tnt-asset-link">
        

        
            Wall Street stalls; S&P 500 drifts after 5-day win streak</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/business/postal-service-loses-2-2b-in-3-months-as-virus-woes-persist/article_e638136e-2ea9-5d68-b02b-0aaab89cf766.html" class="tnt-asset-link">
        

        
            Postal Service loses $2.2B in 3 months as virus woes persist</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/business/us-sanctions-pro-china-leader-of-hong-kong-other-officials/article_f428f7ff-061e-55fa-b7d1-fe9cd89e65f9.html" class="tnt-asset-link">
        

        
            US sanctions pro-China leader of Hong Kong, other officials</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/virus-resistant-worlds-longest-yard-sale-still-lines-roads/article_c1e67edf-164d-5127-a2ab-7fcdad26fa31.html" class="tnt-asset-link">
        

        
            Virus resistant: World's Longest Yard Sale still lines roads</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/business/virus-aid-talks-on-brink-of-collapse-sides-very-far-apart/article_4c967c59-6a7a-5b47-bb5c-619f860faca2.html" class="tnt-asset-link">
        

        
            Virus aid talks on brink of collapse; sides 'very far apart'</a></span>
        </li></ul></div>
        </div></div></section></div></div><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-big-ad-top" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-top');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-559353" class="tncms-block"><div id="origami-ad-container"></div>
<script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="43bcc9d2-1bdd-417a-a442-02cb7334d01e">
</script></div><div id="tncms-block-553127" class="tncms-block"><section id="block-553127" class="block emphasis-h3 dark  " ><div class="clearfix">
    
    <div class="block-title title-553127 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/news/local/">
                
                Local
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-md">
        
                
                <article id="card-summary-553127-3d5934ed-4709-5222-a0c0-1fc64046e351" class="tnt-asset-type-article clearfix card summary has-image image-left dark letterbox-style-  tnt-section-news tnt-sub-section-local">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-3d5934ed-4709-5222-a0c0-1fc64046e351 media-preview article-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/local/masks-with-a-message/article_3d5934ed-4709-5222-a0c0-1fc64046e351.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Article with images"></i> +3</div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Masks with a message"
                            class="img-responsive lazyload full"
                            width="689"
                            height="517"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/4b/04bec1b8-85a0-5a7a-9dfe-28533dfc5929/5f2b134a053b8.image.jpg?crop=689%2C517%2C225%2C145&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/4b/04bec1b8-85a0-5a7a-9dfe-28533dfc5929/5f2b134a053b8.image.jpg?crop=689%2C517%2C225%2C145&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/4b/04bec1b8-85a0-5a7a-9dfe-28533dfc5929/5f2b134a053b8.image.jpg?crop=689%2C517%2C225%2C145&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/4b/04bec1b8-85a0-5a7a-9dfe-28533dfc5929/5f2b134a053b8.image.jpg?crop=689%2C517%2C225%2C145&resize=540%2C405&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/4b/04bec1b8-85a0-5a7a-9dfe-28533dfc5929/5f2b134a053b8.image.jpg?crop=689%2C517%2C225%2C145&resize=689%2C517&order=crop%2Cresize 750w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local/masks-with-a-message/article_3d5934ed-4709-5222-a0c0-1fc64046e351.html" class="tnt-asset-link">
        

        
            Masks with a message</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Area businessmen Willie King Jr. and Ridge Druilhet have collaborated on a face mask project they hope will spread a message of unity while ke&hellip; <a href="/news/local/masks-with-a-message/article_3d5934ed-4709-5222-a0c0-1fc64046e351.html" class="tnt-asset-link read-more-link">Read more</a></p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-553127-07fca00c-5649-5592-80b1-88647c6b29d9" class="tnt-asset-type-article clearfix card summary has-image image-left dark letterbox-style-  tnt-section-news tnt-sub-section-local">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-07fca00c-5649-5592-80b1-88647c6b29d9 media-preview article-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/local/council-defers-ieyoub-request/article_07fca00c-5649-5592-80b1-88647c6b29d9.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Council defers Ieyoub request"
                            class="img-responsive lazyload full"
                            width="800"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/7f/07fca00c-5649-5592-80b1-88647c6b29d9/5f2d734a30a7f.preview.png?crop=800%2C600%2C0%2C22&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/7f/07fca00c-5649-5592-80b1-88647c6b29d9/5f2d734a30a7f.preview.png?crop=800%2C600%2C0%2C22&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/7f/07fca00c-5649-5592-80b1-88647c6b29d9/5f2d734a30a7f.preview.png?crop=800%2C600%2C0%2C22&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/7f/07fca00c-5649-5592-80b1-88647c6b29d9/5f2d734a30a7f.preview.png?crop=800%2C600%2C0%2C22&resize=540%2C405&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/7f/07fca00c-5649-5592-80b1-88647c6b29d9/5f2d734a30a7f.preview.png?crop=800%2C600%2C0%2C22&resize=750%2C563&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/7f/07fca00c-5649-5592-80b1-88647c6b29d9/5f2d734a30a7f.preview.png?crop=800%2C600%2C0%2C22&resize=800%2C600&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local/council-defers-ieyoub-request/article_07fca00c-5649-5592-80b1-88647c6b29d9.html" class="tnt-asset-link">
        

        
            Council defers Ieyoub request</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">The City Council decided to defer a decision on a resolution Lake Charles City Councilman John Ieyoub sponsored that, if approved, would ask L&hellip; <a href="/news/local/council-defers-ieyoub-request/article_07fca00c-5649-5592-80b1-88647c6b29d9.html" class="tnt-asset-link read-more-link">Read more</a></p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-553127-34225706-d8b4-11ea-8f63-638e92d16ffe" class="tnt-asset-type-article clearfix card summary has-image image-left dark letterbox-style-  tnt-section-news tnt-sub-section-local">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-34225706-d8b4-11ea-8f63-638e92d16ffe media-preview article-asset" data-aspect="4:3"><figure class="photo layout-horizontal letterbox-style-">
            <div class="image" 
                >
                
                    <a href="/news/local/jeff-davis-deputy-dies-of-covid/article_34225706-d8b4-11ea-8f63-638e92d16ffe.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Jeff Davis deputy dies of COVID"
                            class="img-responsive lazyload full"
                            width="438"
                            height="329"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/07/00752572-d8b5-11ea-ac2a-9327a6e036fd/5f2d5c4e7dff4.image.jpg?crop=438%2C329%2C0%2C137&resize=200%2C150&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/07/00752572-d8b5-11ea-ac2a-9327a6e036fd/5f2d5c4e7dff4.image.jpg?crop=438%2C329%2C0%2C137&resize=300%2C225&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/07/00752572-d8b5-11ea-ac2a-9327a6e036fd/5f2d5c4e7dff4.image.jpg?crop=438%2C329%2C0%2C137&resize=400%2C300&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/americanpress.com/content/tncms/assets/v3/editorial/0/07/00752572-d8b5-11ea-ac2a-9327a6e036fd/5f2d5c4e7dff4.image.jpg?crop=438%2C329%2C0%2C137&resize=438%2C329&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local/jeff-davis-deputy-dies-of-covid/article_34225706-d8b4-11ea-8f63-638e92d16ffe.html" class="tnt-asset-link">
        

        
            Jeff Davis deputy dies of COVID</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">JENNINGS — A Jeff Davis Parish Sheriff’s Office deputy died Tuesday after battling with the coronavirus since early July.  <a href="/news/local/jeff-davis-deputy-dies-of-covid/article_34225706-d8b4-11ea-8f63-638e92d16ffe.html" class="tnt-asset-link read-more-link">Read more</a></p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-big-ad-middle" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-middle');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-814167" class="tncms-block"><strong><h3>Mozaic Social</h3></strong>Discover Southwest Louisiana businesses on social media <p> 
<iframe src="https://americanpress.friends2follow.com/f2f/widget/html/socialstack/5/0/20/140/1/1/1/9/9/1" width="100%" height="617px" frameborder="0" scrolling="no"></iframe></p></div><div id="tncms-block-659507" class="tncms-block"><var id="ownlocal"><script id="ownlocal-script" data-active="businesses" src="https://local.americanpress.com/embed.js?h=500&amp;min_featured_level=0&amp;category=all&amp;subcategory=all&amp;days_ago=30"></script></var></div><div id="tncms-block-553136" class="tncms-block"><section id="block-553136" class="block emphasis-h3 dark  " ><div class="clearfix">
    
    <div class="block-title title-553136 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/news/national">
                
                National
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-circle"><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/winfrey-demanding-justice-for-breonna-taylor-with-billboards/article_1bb48e1e-3831-567d-8317-7550be68461a.html" class="tnt-asset-link">
        

        
            Winfrey demanding justice for Breonna Taylor with billboards</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/cuomo-clears-new-york-schools-statewide-to-open-carefully/article_dc22a063-1f10-504d-81ba-f15565330a88.html" class="tnt-asset-link">
        

        
            Cuomo clears New York schools statewide to open, carefully</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/virus-resistant-worlds-longest-yard-sale-still-lines-roads/article_c1e67edf-164d-5127-a2ab-7fcdad26fa31.html" class="tnt-asset-link">
        

        
            Virus resistant: World's Longest Yard Sale still lines roads</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/day-turns-up-heat-in-warmer-than-expected-round-1-of-pga/article_212e7932-9c32-54fc-8c5d-43c06ec912c6.html" class="tnt-asset-link">
        

        
            Day turns up heat in warmer-than-expected Round 1 of PGA</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/virus-diary-we-eloped-just-not-the-way-wed-planned/article_dd2583c2-913c-5ed1-aa46-a73515f2e466.html" class="tnt-asset-link">
        

        
            VIRUS DIARY: We eloped, just not the way we'd planned</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/job-losses-fear-of-virus-complicate-latino-voter-hopes/article_35a38f10-4c91-5f0e-82de-75cebf87e9d8.html" class="tnt-asset-link">
        

        
            Job losses, fear of virus complicate Latino voter hopes</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/virus-diary-we-eloped-just-not-the-way-wed-planned/article_3d315eda-2218-597a-8251-a7eec59c3146.html" class="tnt-asset-link">
        

        
            VIRUS DIARY: We eloped, just not the way we'd planned</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/national/alabama-high-school-football-team-band-under-quarantine/article_84e4c21d-b41b-5312-bde5-2edbfb78220d.html" class="tnt-asset-link">
        

        
            Alabama high school football team, band under quarantine</a></span>
        </li></ul></div>
        </div></div></section></div></div><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-big-ad-bottom" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-bottom');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"><div id="tncms-block-549007" class="tncms-block"><section id="block-549007" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-549007 ">
        <div class="block-title-inner">
            <h3>
                
                Online Poll
                
            </h3>
        </div>
    </div>
    <div class="block-note block-note-549007 text-muted">
        <p>We want your feedback!</p>
    </div>
</div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/what-other-kind-of-newsletters-do-you-want-to-see/poll_50811508-0527-11e8-9a58-734c6d3a8ee0.html" class="tnt-asset-link">
        

        
            What other kind of newsletters do you want to see?</a></h4>
            <div id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                    <p>Our newsletters deliver news directly to you in your inbox. </p>
                <div id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-your-vote"></span>
                </div>
                <div id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-results" class="tnt-poll-results hide"></div>
                <div id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-container">
                    <form id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-form" class="tnt-poll-form" role="form" method="post" action="/what-other-kind-of-newsletters-do-you-want-to-see/poll_50811508-0527-11e8-9a58-734c6d3a8ee0.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Scene" value="C7DA8FBC-7E90-0001-844917B040501782"> Scene
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Crime" value="C7DA8FBF-B200-0001-E07B1B9B1CF81FA0"> Crime
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Obit" value="C7DA9089-27B0-0001-1FED1370A1D41853"> Obit
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="National" value="C7DA8FBD-F300-0001-4E782830143E1330"> National
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-back-vote" class="padding-top hide">
                <button id="poll-50811508-0527-11e8-9a58-734c6d3a8ee0-549007-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div><div class="container-breakout"><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-leaderboard-bottom" class="tnt-ads dfp-ad" style="min-height:90px; min-width:728px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-bottom');
                        
                });
            </script>
        </div>
    </div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg " >
        <div id="fixed-leaderboard-bottom-mobile" class="tnt-ads dfp-ad" style="min-height:50px; min-width:320px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-bottom-mobile');
                        
                });
            </script>
        </div>
    </div></div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-549064" class="tncms-block"><section id="block-549064" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-549064 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-scene"  href="/scene/" >
                    <span class="nav-label">Scene</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photos"  href="/photos/" >
                    <span class="nav-label">Photos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obits"  href="/obituaries/" >
                    <span class="nav-label">Obits</span>
                </a></li><li>
                <a class="nav-link  tnt-section-epaper"  href="/zsystem/olive-epaper-form/html_aaaf00c6-398f-11e7-ac83-77a37e59a3a6.html" >
                    <span class="nav-label">ePaper</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-549015" class="tncms-block"><section id="block-549015" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-549015 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-advertising"  href="/advertising/" >
                    <span class="nav-label">Advertising</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-circulation-login"  href="https://lakecharlesla.circulationpro.com/scripts/WebObjects.exe/LakeCharlesSubscriberWeb"  target="_blank" rel="noopener">
                    <span class="nav-label">Circulation Login</span>
                </a></li><li>
                <a class="nav-link  tnt-section-paper-subscription"  href="/zsystem/newspaper-subscription/html_344cab5e-3a5c-11e7-8742-73f63a28f49f.html" >
                    <span class="nav-label">Paper Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-549066" class="tncms-block"><section id="block-549066" class="block emphasis-h4   " ><address>
    <strong>americanpress.com</strong><br>
    4900 Highway 90 East<br>
    Lake Charles, LA 70615
    <br>
    
        <strong>Phone:</strong> 337-433-3000<br>
        <strong>Email:</strong> <a href="mailto:news@americanpress.com">news@americanpress.com</a><br>
    
</address></section></div><div id="tncms-block-549074" class="tncms-block"><div class="follow-links-549074 default">
    
    <section id="block-549074" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/americanpress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/AmericanPress/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/c/lcamericanpress" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/lcamericanpress/?hl=en" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.americanpress.com",
  "sameAs" : ["https://www.facebook.com/americanpress/","https://twitter.com/AmericanPress/","https://www.youtube.com/c/lcamericanpress","https://www.instagram.com/lcamericanpress/?hl=en"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-549019" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-549019"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">American Press</a>, 4900 Highway 90 East Lake Charles, LA</small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    <div class="tnt-ads-container text-center  " >
        <div id="fixed-impact-bottom" class="tnt-ads dfp-ad" style="min-height:1px; min-width:1px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-impact-bottom');
                        
                });
            </script>
        </div>
    </div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in',
                                message = document.getElementById('blox-message-incompatible');

                            Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                el.style.display = 'block';
                            });
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                            }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            <div id="blox-message-incompatible" class="notification wall alert alert-dismissable alert-warning hidden-print" data-message="blox ad blocker" style="display:none;">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <h4 class="clearfix meter-heading  media-heading row">
            Ads are being blocked by your browser.
        </h4>
        <p><strong>Please</strong> disable your ad blocker, whitelist our site, or <a class="alert-link" href="https://www.americanpress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.americanpress.com%252Fnews%252Fstate%252Fcassidy-we-cannot-let-americans-down%252Farticle_b0bc3508-e2a7-5552-bf12-3e760c29180e.html">purchase a subscription</a></p>
    </div>
</template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("b0bc3508-e2a7-5552-bf12-3e760c29180e")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.1509acefe2ad7aac108313ac4c477d63.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/americanpress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ (function() {
                    window.addEventListener('load', function() {
                        __tnt.regions.stickySide.init(document.getElementById('sticky-right-rail'), document.getElementById('sticky-right-rail-spacer'), 'siderail', '.row');
                    });
                })(); /*]]>*/</script></body>
</html>